1

mandag, 27. februar 2017, 18:57


Jeg har en Raspberry pi 3 oppe og køre med OSMC (Kodi) mediacenter og den virker sådan set fint nok. Problemet er, at jeg ikke kan se de mediafiler jeg har liggende på den USB 3 memory stick jeg har siddende i min router. Jeg kan fra mit tv browse helt ind i det korrekte katalog, men altså ikke se nogen af de filer der ligger der. Hvad hulen er der galt?

Jeg kan fint både se, slette og skrive nye filer til memory stick’en i routeren fra min Window 10 maskine.

Det jeg finder mest aparte er, at både routeren og hindbærret er Linux baseret, så hvorfor hulen spille det ikke bare sammen ”out-of-the-box”, når nu det virker fint mellem en Linux boks og en Windåse? – der ville jeg måske endda have forventet problemer…

Prøver jeg at logge ind fra en virtuel VMware Player session, kørende Ubuntu 16.04, så kommer jeg ikke engang ind. RT-AC88U Samba serveren ses og der spørges om brugernavn, domain og password, men jeg får ikke lov at logge ind.

Hvis jeg tillader anonym adgang, så har den virtuelle Ubuntu klient ingen problemer, mens Raspberry mediacenter dimsen nu i stedet melder ”Fejl 2: Netværksmappe ikke tilgængelig”…

Jeg tror ikke jeg kan pille ved rettighedstildelingen i ruteren - ud over det jeg kan gør i de browserbaserede menuer.

Nogen gode ideer ... inden jeg kommer til at "raseribeskadige" et eller andet?


Det ser sådan ud: https://www.asus.com/us/support/FAQ/1011279/ - og jeg har gjort nøjagtigt som der står.


2

tirsdag, 28. februar 2017, 17:26


Jeg har fået løst mine problemer.

Asus benytter angiveligt en ældre version af Samba serveren i deres router med ringere sikkerhedsunderstøttelse, så man er nødt til at nedgradere sin klient tilsvarende.

Jeg tilføjede følgende to linjer i /etc/samba/smb.conf filen under [Global] sektionen:

client use spnego = no
client ntlmv2 auth = no

Efter en genstart kan jeg nu logge ind og benytte det delte usb-stick fra min virtuelle Ubuntu klient, på helt samme måde som jeg kan fra Windows.



Med hensyn til OSMC Mediacenteret må jeg med meget røde kinder tilstå en brugerfejl. Jeg opdagede sent i nat, at hvis jeg gik ind i filhåndtering så kunne jeg se alle mine film. Det jeg forsøgte at gøre, var at se selve filerne der hvor man adderer nye delte mapper til menuerne for Film, Videoer etc. Efter at en delt mappe på en Samba server er adderet til listen, så kan se alle filer og undermapper.

Btw: Jeg nåede at tilføre ovenstående ændring i min smb.conf fil på mediacenteret, så om det har bidraget til at det nu virker ved jeg ikke – de par linjer får bare lov til at være der.


3

tirsdag, 28. februar 2017, 19:21


Fantastisk du tilmed skriver løsningen i forummet. :goodpost: :dance:


Nyeste Videoer og Trailers

Partner sider
Indsend nyhed
Har du fundet en fed nyhed så indsend den så alle andre på Tweak.dk kan få glæde af den.