1

mandag, 1. juni 2015, 11:23


Jeg har længe siddet med en besynderlig ting på alle mine Win 8.1 (Pro og Enterprise) maskiner.
Hvis jeg vælger Chrome eller Firefox som min standard browser, holder samtlige IE genveje op med at virke. I stedet for at åbne IE åbner de den respektive default browser - med mindre jeg højreklikker og vælger "Kør som administrator". Så åbner IE som den skal.

Jeg kan simpelthen ikke lure hvad der er galt. Lige nu omgår jeg det vha en scheduled task som jeg kalder med cmd. Det kan dog ikke være rigtigt at det skal foregå på denne måde.
Desværre har jeg ikke haft held til at google mig til en løsning.

Nogle der har den gyldne løsning?

CPU i7-4790k
MB ASRock Z97 Pro4
GFX Asus GTX770
RAM Kingston HyperX Fury 16GB
SSD Samsung 840 Evo 250GB
PSU Corsair RM550
Dual Boot Windows 10 Pro & macOS Sierra

2

mandag, 1. juni 2015, 13:47


det er .lnk filen du skal ind og sætte til at bruge IE i Windows.

Default programs --> Set Associations og find .lnk på listen tryk på den og tryk på knappen Change program...

Så kender du vel resten af vejen Grus?




3

mandag, 8. juni 2015, 16:23


det er .lnk filen du skal ind og sætte til at bruge IE i Windows.

Default programs --> Set Associations og find .lnk på listen tryk på den og tryk på knappen Change program...

Så kender du vel resten af vejen Grus?


Nope. Virkede ikke.
.lnk er da også en lidt for global filtype at sætte til IE? Det er jo bare en genvej til whatever.

CPU i7-4790k
MB ASRock Z97 Pro4
GFX Asus GTX770
RAM Kingston HyperX Fury 16GB
SSD Samsung 840 Evo 250GB
PSU Corsair RM550
Dual Boot Windows 10 Pro & macOS Sierra

4

mandag, 8. juni 2015, 16:31


det er .lnk filen du skal ind og sætte til at bruge IE i Windows.

Default programs --> Set Associations og find .lnk på listen tryk på den og tryk på knappen Change program...

Så kender du vel resten af vejen Grus?


Nope. Virkede ikke.
.lnk er da også en lidt for global filtype at sætte til IE? Det er jo bare en genvej til whatever.


Hmm ja ved at bookmarks er lnk filer, men kan godt ske at det er fordi du vil ha en anden standard browser som kun administrator kan omgå i windows at du så ikke kan få det til det.




5

mandag, 8. juni 2015, 20:18


det er .lnk filen du skal ind og sætte til at bruge IE i Windows.

Default programs --> Set Associations og find .lnk på listen tryk på den og tryk på knappen Change program...

Så kender du vel resten af vejen Grus?


Nope. Virkede ikke.
.lnk er da også en lidt for global filtype at sætte til IE? Det er jo bare en genvej til whatever.


Hmm ja ved at bookmarks er lnk filer, men kan godt ske at det er fordi du vil ha en anden standard browser som kun administrator kan omgå i windows at du så ikke kan få det til det.


Det er virkelig besynderligt.
Hvis jeg sætter IE til at være standardbrowser så kan man godt åbne IE uden "kør som administrator".
Det mærkelige er at når jeg vælger genvejen i Start menuen, som peger direkte på "C:\Program Files\Internet Explorer\iexplore.exe" - ja, så åbner den Firefox eller Chrome, hvis én af de to er standard.

Den vil kun åbne IE hvis den er standardbrowser. På trods af den peger direkte på iexplore.exe.

Det er mig et mysterie uden lige. Og jeg kan intet finde på google om andre der skulle opleve det samme. Jeg kunne forstå hvis det skete på én af mine maskiner, men når det er på dem alle den er gal, så forvirrer det mig altså.

CPU i7-4790k
MB ASRock Z97 Pro4
GFX Asus GTX770
RAM Kingston HyperX Fury 16GB
SSD Samsung 840 Evo 250GB
PSU Corsair RM550
Dual Boot Windows 10 Pro & macOS Sierra

6

tirsdag, 9. juni 2015, 13:34


Så er der udvikling i sagen.
Det sker tilsyneladende kun når jeg bruger de "originale" genveje til IE - dvs. dem der ligger i startmenuen, taskbaren og på skrivebordet.

Hvis jeg manuelt opretter en ny genvej til iexplore.exe så virker alt som det skal.
Måske jeg skal en tur i registreringsdatabasen og kigge lidt.

Her har vi løsningen:
Efter en lille tur igennem regedit fandt jeg følgende key:

HKCU\Software\Classes\Microsoft.InternetExploer.Default\.exe\shell\open\command

Strengværdien var sørme "c:\program files (x86)\mozilla firefox\firefox.exe".
Jeg ændrede den til "C:\Program Files\Internet Explorer\iexplore.exe" - nu virker det.

CPU i7-4790k
MB ASRock Z97 Pro4
GFX Asus GTX770
RAM Kingston HyperX Fury 16GB
SSD Samsung 840 Evo 250GB
PSU Corsair RM550
Dual Boot Windows 10 Pro & macOS Sierra

Dette indlæg er blevet redigeret 1 gange, senest redigeret af "Grus" (09.06.2015, 13:49)


Nyeste Videoer og Trailers

Indsend nyhed
Har du fundet en fed nyhed så indsend den så alle andre på Tweak.dk kan få glæde af den.