Kære gæst, velkommen til Tweak.dk. Hvis dette er dit første besøg her, bør du læse Hjælp. Her forklares i detaljer hvordan denne side fungerer. For at benytte alle funktionerne på denne side, bør du overveje at lade dig registrere. Benyt venligst registreringsformularen for at registrere her eller læs yderligere information om registreringsprocessen. Hvis du allerede er registreret, så log på her.

1

lørdag, 22. januar 2011, 13:17


Hej alle tweakers. Jeg famler lidt i mørke med excelprogrammering, så måske vil i hjælpe mig? :)

Jeg er igang med at lave et excelark der kan regne ud hvor mange timer der skal tillæg på ud fra om det er hverdag, lørdag eller søndag. Benarbejdet er lavet, men nu kan jeg bare ikke for felterne til at gøre som jeg. Hovedproblemet er at den celle der udregner "timer m. tillæg på en lørdag" ud, ikke rigtigt tager hensyn til om det er lørdag eller ej.

Det skal lige siges at i celle K3 står der =UGEDAG(A3;2) - og i A3 står der en dato. Så vidt jeg er klar over udregner UGEDAG() hvilken dag datoen er, og returnerer et tal fra 1 (mandag) - 7 (søndag)

Timer m. tillæg på en hverdag: =HVIS(K3<6&C3>15;C3-18;0)
Timer m. tillæg på en lørdag: =HVIS(K3=6&C3>18;C3-15;0)

Ved ikke helt om det er rigtigt at bruge "&"-tegnet til at få flere betingelser i HVIS(), men Excel klager ikke.

Håber virkelig nogen kan finde fejlen ;)

MSI Z87-G43 GAMING (MS7816) NVIDIA GeForce GTX 760
Intel Core i5-4670k (3,4 GHz) 8 GB RAM
Samsung SSD 840 EVO 250 GB Samsung SpinPoint F1 Desktop 750GB 32MB 7200 RPM

Nyeste Videoer og Trailers

Partner sider
Indsend nyhed
Har du fundet en fed nyhed så indsend den så alle andre på Tweak.dk kan få glæde af den.