1

mandag, 20. november 2006, 13:25


Hey alle sammen! :clap:

Jeg står og skal igang med PHP og jeg har installeret IIS og den nyeste PHP fra PHP.net, men når jeg køre denne simple kode (bare for at se om IIS virkede):

Citeret


<html>
<body>
<? echo "1234567890"; ?>
</body>
</html>


... får jeg dette resultat:

Citeret


CGI Error
The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:


1234567890


Jeg HAR prøvet google, der kom med en milliard resultater der passede perfekt på min søgning, men jeg kunne ikke grave nogen løsning frem.

Det skal siges at jeg har installeret IIS og PHP på både min stationære og min bærbar, og dette problem kommer kun på min bærbar...

Nogen der kender en løsning :boxed:


2

mandag, 20. november 2006, 13:37


Prøv PHP.net:
http://bugs.php.net/bug.php?id=25863

En mulig løsning derfra er en patch fra MS:
http://support.microsoft.com/default.asp…kb;EN-US;884764

Der er også et par andre muligheder på PHP siden.


3

mandag, 20. november 2006, 14:29


HAHAHA... jeg glemte lige én lille faktor... På min stationære brugte jeg Macromedia Dreamweaver 8 til at lave PHP filen og på den stationære lavede jeg den igennem Notesblok... Det er der problemet ligger...

Men tak for hjælpen :D


4

mandag, 20. november 2006, 14:42


Citeret

Originally posted by Xdreamer
HAHAHA... jeg glemte lige én lille faktor... På min stationære brugte jeg Macromedia Dreamweaver 8 til at lave PHP filen og på den stationære lavede jeg den igennem Notesblok... Det er der problemet ligger...

Men tak for hjælpen :D


Det lyder da godt nok noget usandsynligt..... arbejder tit både i notepad og dreamweaver uden problemer, men leger selvfølgelig så heller ikke med ISS


5

mandag, 20. november 2006, 14:49


Kan den godt selv finde ud af at <? echo "blah"; ?> er php?
Er det ikke nødvendigt at skrive <?php echo "blah"; ?> ?


6

mandag, 20. november 2006, 14:52


Citeret

Originally posted by fhqwhgad
Kan den godt selv finde ud af at <? echo "blah"; ?> er php?
Er det ikke nødvendigt at skrive <?php echo "blah"; ?> ?


Hvis PHP er sat op til det ja (det er det vist som standard)

kan enda også skrives som
<?="blah"?>

hvis det skal gå rigtigt hurtigt


7

mandag, 20. november 2006, 14:59


Citeret

Originally posted by WebT

Citeret

Originally posted by Xdreamer
HAHAHA... jeg glemte lige én lille faktor... På min stationære brugte jeg Macromedia Dreamweaver 8 til at lave PHP filen og på den stationære lavede jeg den igennem Notesblok... Det er der problemet ligger...

Men tak for hjælpen :D


Det lyder da godt nok noget usandsynligt..... arbejder tit både i notepad og dreamweaver uden problemer, men leger selvfølgelig så heller ikke med ISS


Det er rigtigt... det giver to forskellige resultater... tro det eller ej... lol


8

mandag, 20. november 2006, 18:48


Citeret

Originally posted by Xdreamer
Det er rigtigt... det giver to forskellige resultater... tro det eller ej... lol


Mystisk mystisk, måske noget med tegnsæt, men tror den patch fra MS er en god ide lige meget hvad, fordi det er jo ikke en korrekt handlemåde for IIS at diskriminerer editorer på den måde. Det er jo direkte politisk ukorrekt at diskriminere FYFY IIS


Nyeste Videoer og Trailers

Indsend nyhed
Har du fundet en fed nyhed så indsend den så alle andre på Tweak.dk kan få glæde af den.