Kære gæst, velkommen til Tweak.dk. Hvis dette er dit første besøg her, bør du læse Hjælp. Her forklares i detaljer hvordan denne side fungerer. For at benytte alle funktionerne på denne side, bør du overveje at lade dig registrere. Benyt venligst registreringsformularen for at registrere her eller læs yderligere information om registreringsprocessen. Hvis du allerede er registreret, så log på her.

1

søndag, 20. februar 2011, 00:31


Hejsa
jeg sidder med en server hvor jeg har et onboard gbit netkort, det er sat op til at modtage wol og reagere på det. Det reagere dog ikke når jeg lukker maskinen ned og vil tænde den igen.
men hvis jeg går i bios og saver/exit og så holder power knappen inde så den slukker, så kan jeg godt tænde den med wol.
Hvad kan dette skyldes?
Bundkortet er et asus p4pe

Edit: Når jeg tager strøm kablet ud og sætter det i igen, så starter maskinen lige hurtigt og slukker igen. Og så fungere wol. men lige så snart jeg bare lukker den alm ned så fungere det ikke??

Mvh Jens

Dette indlæg er blevet redigeret 2 gange, senest redigeret af "Jens ledet" (20.02.2011, 00:52)


2

søndag, 20. februar 2011, 02:14


Nu ved jeg ikke hvilket OS du bruger, men jeg har tidligere oplevet at jeg skulle aktivere WOL både i BIOS og i driveren.

Det var så under Windows, så YMMV, men det er da et forsøg værd at undersøge.

Husk at tænke dig om inden du poster, underbyg gerne svar med argumenter baseret på fakta og husk kilder.

3

søndag, 20. februar 2011, 02:23


Det er en ubuntu server 10.4
Og der aner jeg ikke hvordan man gør.
Men jeg mistænker bare lidt bundkortet fordi at det virker når man har taget strømmen helt...
Det jeg har kunne finde på nettet om wol på det bundkort er alt muligt andet plus at folk "klager" over at wol ikke virker efter strømmen er taget til maskinen... ved mig er det så bare omvendt...
Jeg havde samme problem da det var en win 2008 server..

Mvh Jens


4

søndag, 20. februar 2011, 11:36


Har du kigget på at opdatere BIOS på det bundkort?

Hvis du stadigvæk kører med den første BIOS opdatering, kan det være årsagen, asus skriver følgende til en af BIOS opdateringerne:

Citeret

P4PE BIOS 1002 Add check and correct code to patch Broadcom Lan Chip EEPROM first byte be destroyed issue after AC power lost


Kunne måske være det...

Husk at tænke dig om inden du poster, underbyg gerne svar med argumenter baseret på fakta og husk kilder.

5

søndag, 20. februar 2011, 11:52


Ser i øvrigt ud at man skal aktivere det på computeren igennem OS også på Linux.

Her er et eksempel på hvordan det ser ud på en Gentoo installation: LINK

Princippet burde være det samme på din ubuntu server maskine.

Husk at tænke dig om inden du poster, underbyg gerne svar med argumenter baseret på fakta og husk kilder.

6

søndag, 20. februar 2011, 13:39


Bios er opdateret. det er vers 1007.

men hvis det ikke var aktiveret via linux så ville den vel slet ikke reagere?
Det gør den jo når først strømmen er taget..
Mvh Jens


7

søndag, 20. februar 2011, 15:15


Citeret

Oprindeligt indlæg af Jens ledet
Bios er opdateret. det er vers 1007.

men hvis det ikke var aktiveret via linux så ville den vel slet ikke reagere?
Det gør den jo når først strømmen er taget..
Mvh Jens


Det jeg tror der sker er at driveren under Linux deaktiverer det hver gang den bliver loadet.

Men hvis du kigger på den guide til gentoo, kan du se hvordan det ser ud hvis det er deaktiveret og hvordan du aktiverer det.

Hvis du er i tvivl hvordan du installerer ethtool, er det sandsynligvis på denne måde:

Kildekode

1
sudo aptitude install ethtool


Til sammenligning kan jeg nævne at på min debian(ubuntu er baseret på debian) installation er det deaktiveret.

Hvis du kun har et netkort i den computer er dit netkort i øvrigt sandsynligvis på eth0 (gentoo guiden viser eth1, bare så der ikke er nogen forvirringer).

Husk at tænke dig om inden du poster, underbyg gerne svar med argumenter baseret på fakta og husk kilder.

8

søndag, 20. februar 2011, 18:18


Jeg fik ethtool instaleret. Men det hjalp ikke.
Jeg fandt denne how to men den er vist så gammel at den ikke virker mere.
Det virker hvertfald ikke at bruge den manuelle del af den

http://ubuntuforums.org/showthread.php?t=234588

Mvh Jens


9

søndag, 20. februar 2011, 18:40


Citeret

Oprindeligt indlæg af Jens ledet
Jeg fik ethtool instaleret. Men det hjalp ikke.
Jeg fandt denne how to men den er vist så gammel at den ikke virker mere.
Det virker hvertfald ikke at bruge den manuelle del af den

http://ubuntuforums.org/showthread.php?t=234588

Mvh Jens


Hvad fortæller ethtool dig angående om WOL er aktiveret eller ej?

Min ser sådan ud når jeg lige har genstartet computeren:

Citeret

Supports Wake-on: umbg
Wake-on: d


Wake-on: d betyder at der ikke er aktiveret noget og supports wake-on: umbg betyder at den understøtter 4 forskellige typer af WOL. De typer kan afkodes ved at læse manpagen til ethtool:

Citeret


wol p|u|m|b|a|g|s|d...
Sets Wake-on-LAN options. Not all devices support this. The
argument to this option is a string of characters specifying
which options to enable.
p Wake on phy activity
u Wake on unicast messages
m Wake on multicast messages
b Wake on broadcast messages
a Wake on ARP
g Wake on MagicPacket(tm)
s Enable SecureOn(tm) password for MagicPacket(tm)
d Disable (wake on nothing). This option clears all previous
options.


For at aktivere de fire forskellige typer kørte jeg følgende kommandoer(på ubuntu skal du tilføje sudo først eller tilsvarende:

Citeret


ethtool -s eth0 wol umbg
ethtool eth0


Derefter står der dette når man kører ethtool:

Citeret


Supports Wake-on: umbg
Wake-on: umbg


Hvilket betyder at de fire typer for WOL nu er aktiveret. Bemærk at efter jeg genstartede computeren var WOL tilbage til at være deaktiveret.

Så hvis det virker 1 gang efter du har kørt disse kommandoer, så er det linux driveren der går ind og deaktiverer WOL hver gang. Så bliver du sandsynligvis nødt til at lave et script (eller andet) der gør at kommandoen bliver kørt hver gang.

Husk at tænke dig om inden du poster, underbyg gerne svar med argumenter baseret på fakta og husk kilder.

10

søndag, 20. februar 2011, 18:47


Okay når jeg skriver det kommer den med:
Supports Wake-on: g
Wake-on: g
Current message level: 0x000000ff (255)
Link detected: yes



Som det sidste af en lang s,øre om duplex og half duplex osv

Passer det ?


11

søndag, 20. februar 2011, 18:54


Nåe jeg nu ser efter skriver den faktisk
Cannot set new wake-on-lan settings: Invalid argument
efter jeg har givet comandoen:
ethtool -s eth0 wol umbg


Mvh Jens


12

søndag, 20. februar 2011, 19:13


Citeret

Oprindeligt indlæg af Jens ledet
Nåe jeg nu ser efter skriver den faktisk
Cannot set new wake-on-lan settings: Invalid argument
efter jeg har givet comandoen:
ethtool -s eth0 wol umbg


Mvh Jens


Så vidt jeg kan se understøtter din pc kun wol type "g" så du skal ikke skrive ubmg, men kun "g", så er sikkert derfor den fejler.

Den øverste linje af de to fortæller at den kun understøtter 1 type WOL (g Wake on MagicPacket(tm)).
Så er en naturlig konsekvens af at du prøver at aktivere noget som ikke understøttes.

Husk at tænke dig om inden du poster, underbyg gerne svar med argumenter baseret på fakta og husk kilder.

13

søndag, 20. februar 2011, 19:15


Citeret

Oprindeligt indlæg af Jens ledet
Okay når jeg skriver det kommer den med:
Supports Wake-on: g
Wake-on: g
Current message level: 0x000000ff (255)
Link detected: yes



Som det sidste af en lang s,øre om duplex og half duplex osv

Passer det ?


Der ser rigtigt ud, hvis du prøver at slukke computeren og derefter vække den med en WOL magicpacket, så er der en mulighed for at det virker.

Hvis der står "wake-on: d" igen efter reboot, betyder det at ændringerne ikke gemmes for hver boot og som sagt skal gøres hver gang du booter eller på anden vis gøre ændringen persistent.

Husk at tænke dig om inden du poster, underbyg gerne svar med argumenter baseret på fakta og husk kilder.

14

søndag, 20. februar 2011, 19:16


Ja selfølgelig :-)
Man hvad gør jeg så?
jeg kan jo godt vække den med en magic pakke når først jeg har taget strømmen fra kabinettet og sat det på igen.
Er der en måde at den deaktivere wol under power down? og hvor/hvordan kan jeg ændre dette?
Og hvordan bliver det enablet bare fordi 230v bliver taget fra den og sat på igen?
Mvh Jens

Dette indlæg er blevet redigeret 1 gange, senest redigeret af "Jens ledet" (20.02.2011, 19:19)


15

søndag, 20. februar 2011, 19:26


Citeret

Oprindeligt indlæg af Jens ledet
Ja selfølgelig :-)
Man hvad gør jeg så?
jeg kan jo godt vække den med en magic pakke når først jeg har taget strømmen fra kabinettet og sat det på igen.
Er der en måde at den deaktivere wol under power down? og hvor/hvordan kan jeg ændre dette?

Mvh Jens


Jeg tror vi misforstår hinanden :(

Jeg prøver at starte forfra, er nok nemmere, hvis du følger det lidt slavisk så burde vi kunne afgrænse det hurtigt.

Start med at genstarte din computer(på normal vis hvor det ikke virker) og derefter køre følgende kommando:

sudo ethtool eth0

Hvad skriver den ud for "Wake-on:" ?

Hvis der står g, så er det fint, så er den sat op til at kunne vække computeren med en magic packet.
Hvis der står d, betyder det at det er deaktiveret.

############################################

Hvis det er deaktiveret skal det aktiveres ved at du skriver:
sudo ethtool -s eth0 wol g

bekræft at det er aktiveret ved at køre denne kommando:
sudo ethtool eth0

Der skal stå g ud for "wake-on:" for at det er aktiveret.

Prøv så at genstarte computeren(på almindelige vis, ie. sudo reboot eller lignende) og se om det stadigvæk er aktiveret ved at køre "sudo ethtool eth0" igen.

Hvis det igen er deaktiveret, skal du finde en måde at køre denne kommando hver gang computeren starter ubuntu server, ellers tyder det på at det bliver deaktiveret hver gang driveren bliver loadet.

############################################

Hvis det er aktiveret og du stadigvæk har problemer, skal du lede andet steds efter problemet med WOL.

Husk at tænke dig om inden du poster, underbyg gerne svar med argumenter baseret på fakta og husk kilder.

16

søndag, 20. februar 2011, 19:27


Efter genstart skriver den stadig:
Supports Wake-on: g
Wake-on: g
Current message level: 0x000000ff (255)
Link detected: yes
Så det ser ud til at den gemmer mine ændringer.


HAR FØRST SET DIT INDLÆG NU, ER VED AT FØLGE DET NU! :-)

Dette indlæg er blevet redigeret 1 gange, senest redigeret af "Jens ledet" (20.02.2011, 19:29)


17

søndag, 20. februar 2011, 19:31


Ok så fik jeg læst og kigget.


Efter genstart skriver den stadig:
Supports Wake-on: g
Wake-on: g
Current message level: 0x000000ff (255)
Link detected: yes
Så det ser ud til at den gemmer mine ændringer. og at den er sat til at blive vækket af en magic pakke. Og det kan jeg jo også.. men først efter jeg tager strømmen.
Har du en idé til hvor det så er?
Sorry hvis jeg er alt for newbie men det er min første linux maskine/server

Mvh Jens

Dette indlæg er blevet redigeret 1 gange, senest redigeret af "Jens ledet" (20.02.2011, 19:34)


18

søndag, 20. februar 2011, 19:39


Citeret

Oprindeligt indlæg af Jens ledet
...
Så det ser ud til at den gemmer mine ændringer. og at den er sat til at blive vækket af en magic pakke. Og det kan jeg jo også.. men først efter jeg tager strømmen.
Har du en idé til hvor det så er?
Sorry hvis jeg er alt for newbie men det er min første linux maskine/server

Mvh Jens


Ja det ser ikke ud til at det umiddelbart er linux installationen der giver problemet.

Måske er vi ude i noget lidt anderledes, noget strømstyring måske eller noget mellemliggende hardware der giver problemer(switch osv.).

Hvad bruger du til at vække computeren med? og hvordan er computerene forbundet?

Husk at tænke dig om inden du poster, underbyg gerne svar med argumenter baseret på fakta og husk kilder.

19

søndag, 20. februar 2011, 19:46


Jeg bruger et lille freeware program der hedder
wake-on -lan-sender 2.0 fra min laptop der køre xp

Der er kun min tdc box med router i mellem maskinerne.
Jeg har prøvet at tage min kaspersky firewall fra, men det ændre intet... jeg mistænker også lidt noget hardware i maskinen...
Men jeg kan se at der er strøm på netkortet når maskinen er slukket, der lyser nemlig en lille led.
hvad skulle psuén kunne lave af ged? den skal vel "bare" levere de +5v?
Jeg havde samme problem under en server 2008 server (samme fysiske maskine).. så det burdte næsten ikke være software relateret?

Mvh Jens


20

søndag, 20. februar 2011, 20:08


Citeret

Oprindeligt indlæg af Jens ledet
Jeg bruger et lille freeware program der hedder
wake-on -lan-sender 2.0 fra min laptop der køre xp

Der er kun min tdc box med router i mellem maskinerne.
Jeg har prøvet at tage min kaspersky firewall fra, men det ændre intet... jeg mistænker også lidt noget hardware i maskinen...
Men jeg kan se at der er strøm på netkortet når maskinen er slukket, der lyser nemlig en lille led.
hvad skulle psuén kunne lave af ged? den skal vel "bare" levere de +5v?
Jeg havde samme problem under en server 2008 server (samme fysiske maskine).. så det burdte næsten ikke være software relateret?

Mvh Jens


Tjaa... jeg har prøvet at undersøge det lidt nærmere, kunne se ud til at være noget specifikt med det netkort der benyttes.

Hvis du orker at læse google translate oversat (til engelsk) tysk, kan du se lidt mere på denne side:
Link

Umiddelbart ser det ud til at en person fik det til at virke ved at rekompilere en driver.

Husk at tænke dig om inden du poster, underbyg gerne svar med argumenter baseret på fakta og husk kilder.

Dette indlæg er blevet redigeret 1 gange, senest redigeret af "RTM" (20.02.2011, 20:09)


Nyeste Videoer og Trailers

Partner sider
Indsend nyhed
Har du fundet en fed nyhed så indsend den så alle andre på Tweak.dk kan få glæde af den.